Vitotwin: Software ist seit der Produktpflege nicht mehr zu gebrauchen

  • Hallo,


    Ich denke die meisten kennen die Produktpflege der ersten Vitotwin Generationen bei denen der Stirling-Kopf ausgetauscht wurde und ein Software-Update erfolgt ist.
    Alles schön und gut, nur das die Software schlimmer geworden ist, als zuvor... Hier ein paar meiner Probleme:


    1.) Egal wie die Trinkwasser-Erwärmung konfiguriert ist, es springt IMMER der Zusatzbrenner mit an.
    2.) Taste zur Zwangsladung an der Fernbedienung funktioniert nicht mehr, bzw. hat keine Wirkung. "Speicherzwangsladung Ein" wird angezeigt, aber es passiert nichts.
    3.) Timer 5 zur Speicher-Zwangsladung funktioniert ebenfalls nicht mehr.


    In diesem Zustand ist eine Optimierung des Eigen-Stromverbrauchs kaum möglich und nervt mich tierisch.
    Bitte schreibt mal wer noch alles diese Probleme hat. Punkt 1 wurde ja schon in diversen anderen Threads bestätigt.

  • Moin @Malkwin,


    Hast Du die von Dir bemängelten Punkte gerade jetzt zum ersten Mal beobachtet, oder ist das so schon seit dem Software-Update, das ja schon mindestens ein Jahr her sein müsste, d.h. war es womöglich auch im Winter schon so? Ich frage deshalb, weil jedenfalls die beiden letztgenannten Punkte bei uns nur im sogenannten Sommerbetrieb auftreten.


    Aber der Reihe nach:

    1.) Egal wie die Trinkwasser-Erwärmung konfiguriert ist, es springt IMMER der Zusatzbrenner mit an.

    Bei Unterschreiten der TWW-Einschalttemperatur, d.h. wenn die TWW-Temperatur unter den Wert (Nenntemperatur minus Schaltdifferenz) sinkt, springen immer beide Brenner an. Das war allerdings bei unserem C3HB ab Einbau (Mai 2013) auch schon so, hat also mit dem letzten Software-Update wohl nichts zu tun.


    Normalerweise sollte aber über die sog. Energie-Optimierungsfunktion der Stirling (automatisch) allein mit der TWW-Erwärmung beginnen, sobald die TWW-Temperatur unter den Wert (Nenntemperatur minus halbe Schaltdifferenz) sinkt. Nur ist diese Funktion mit der werksseitig eingestellten sehr geringen Schaltdifferenz (2 K) kaum nutzbar.


    Abhilfe: Du stellst im Menü "Trinkwasser-Speicher" unter Code 5024 (Ebene F2) eine höhere Schaltdifferenz ein, beispielsweise 8 K. Dann müsste sich der Stirling einschalten, sobald die TWW-Temperatur um 4 K unter die TWW-Nenntemperatur absinkt. Also angenommen Du hast für T(Nenn) die Werkseinstellung 60°C beibehalten, dann startet der Stirling, sobald T(TWW) unter 56°C fällt und läuft, bis T(TWW) 60°C erreicht hat. Der Zusatzbrenner geht bei dieser Einstellung erst an, wenn T(TWW) unter 52°C fällt.


    Das läuft jedenfalls so, wenn wie bei uns im Menü "Brennerfolge" unter "Brenn'freigabe TWW Ladung" (Code 3213 in F1) "Nur Stirlingbrenner" eingestellt ist, sowie im Menü "Trinkwasser" unter "Ladevorrang" (Code 1630 in F2) "Gleitend". Ob andere Einstellungen unter diesen Codes die Funktion beeinflussen, habe ich nicht ausprobiert.



    2.) Taste zur Zwangsladung an der Fernbedienung funktioniert nicht mehr, bzw. hat keine Wirkung. "Speicherzwangsladung Ein" wird angezeigt, aber es passiert nichts.
    3.) Timer 5 zur Speicher-Zwangsladung funktioniert ebenfalls nicht mehr.

    Wie oben schon angedeutet, sind anscheinend diese Funktionen nicht schaltbar, wenn und so lange das Gerät im Sommerbetrieb läuft. Sommerbetrieb wird an der Fernbedienung rechts unten angezeigt, wenn man mit der "i"-Taste bis zu "Status Heizkreis" durchklickt. In diesem Betriebszustand ist der Heizkreis ausgeschaltet und das Gerät läuft nur zur TWW-Bereitung.


    Der Sommerbetrieb stellt sich automatisch ein, sobald die gedämpfte Außentemperatur (ablesbar im Menü "Diagnose" unter Code 8703 in F1) den für die Sommer/Winterheizgrenze eingestellten Wert überschreitet. Dieser Wert ist für jeden Heizkreis separat einstellbar, z.B. im Menü "Heizkreis 1" unter Code 730 in F1. Werksseitig sind hier 18°C eingestellt. Wenn also (wie in den letzten Tagen) die unter Code 8703 ablesbare gedämpfte Außentemperatur über 18°C steigt, geht das Gerät in den Sommerbetrieb. Mit einer Regelhysterese von ca. 1 K schaltet es dann wieder auf Winterbetrieb, sobald die gedämpfte AT unter 17°C fällt.


    Du könntest also mal probeweise den Einstellwert unter Code 730 anheben, z.B. auf 20°C, und ausprobieren ob die Stromanforderung dann wieder geht.


    Das mit dem Sommerbetrieb ist an sich eine Energiespar-Funktion und soll verhindern, dass selbst in einem heißen Juli immer die Heizung anspringt, sobald die Außentemperatur morgens mal auf erträgliche 18°C fällt. Dass die Stromanforderungsfunktion in diesem Betriebszustand offensichtlich nicht schaltbar ist, dürfte Sicherheitsgründe haben.


    Gruß, Sailor

    Viessmann Vitotwin 300-W (1 kWel, 6 kWth) seit 2012

    PV-Anlage 8,45 kWp (65 x Solarworld SW 130poly Ost/Süd/West, SMA 5000 TL und 3000) seit 2010

    Solarthermie 14 qm Flachkollektoren seit 2004 (Vorgänger 8 qm 1979-2003)

  • Hast Du die von Dir bemängelten Punkte gerade jetzt zum ersten Mal beobachtet, oder ist das so schon seit dem Software-Update, das ja schon mindestens ein Jahr her sein müsste, d.h. war es womöglich auch im Winter schon so? Ich frage deshalb, weil jedenfalls die beiden letztgenannten Punkte bei uns nur im sogenannten Sommerbetrieb auftreten.

    Nein, das ist seit dem Software-Update, also schon seit über 1 Jahr der Fall...



    Abhilfe: Du stellst im Menü "Trinkwasser-Speicher" unter Code 5024 (Ebene F2) eine höhere Schaltdifferenz ein, beispielsweise 8 K. Dann müsste sich der Stirling einschalten, sobald die TWW-Temperatur um 4 K unter die TWW-Nenntemperatur absinkt. Also angenommen Du hast für T(Nenn) die Werkseinstellung 60°C beibehalten, dann startet der Stirling, sobald T(TWW) unter 56°C fällt und läuft, bis T(TWW) 60°C erreicht hat. Der Zusatzbrenner geht bei dieser Einstellung erst an, wenn T(TWW) unter 52°C fällt..

    Ok, danke muss ich mal ausprobieren. Ich meine mich aber zu erinnern, dass er IMMER beide Brenner aktiviert hat... Unabhängig von den Schaltdifferenzen. Das war vor der Produkpflege definitiv nicht so. Da lief wirklich nur der Sirlingbrenner (C3HA).


    Der Sommerbetrieb stellt sich automatisch ein, sobald die gedämpfte Außentemperatur (ablesbar im Menü "Diagnose" unter Code 8703 in F1) den für die Sommer/Winterheizgrenze eingestellten Wert überschreitet. Dieser Wert ist für jeden Heizkreis separat einstellbar, z.B. im Menü "Heizkreis 1" unter Code 730 in F1. Werksseitig sind hier 18°C eingestellt. Wenn also (wie in den letzten Tagen) die unter Code 8703 ablesbare gedämpfte Außentemperatur über 18°C steigt, geht das Gerät in den Sommerbetrieb. Mit einer Regelhysterese von ca. 1 K schaltet es dann wieder auf Winterbetrieb, sobald die gedämpfte AT unter 17°C fällt.


    Du könntest also mal probeweise den Einstellwert unter Code 730 anheben, z.B. auf 20°C, und ausprobieren ob die Stromanforderung dann wieder geht.

    Der erste Teil ist mir bekannt. Die Umkonfiguration muss ich mal ausprobieren, halte ich aber dennoch für sub-optimal!
    So ist es unmöglich den Eigenstromverbrauch im Sommer zu optimieren...


    Ich habe es im Sommer immer so gehandhabt, dass ich die TWW abgeschaltet habe und nur mit dem Stromanforderungstimer gearbeitet habe. Dieser war auf 19 Uhr eingestellt, so dass ab diesem Zeitpunkt die Stromproduktion begonnen hat. In dieser Zeit haben wir dann Wäsche gewaschen, usw. Dies ist jetzt unmöglich, da der Timer 5 keine Wirkung mehr hat. PLUS: Die Stromanforderungstaste hat keine Funktion mehr, wird in der Bedienungsanleitung aber immernoch als solche benannt.


    Nach Aussage von Viessmann wurde der Timer 5 in der Firmware zum "Sperrtimer" umfunktioniert... Angeblich hätten nicht genug Kunden den Stromanforderungsmodus verwendet, wollten mit dem Sperrtimer aber verhindern, dass der Stirling zu bestimmten Zeiten anspringt... Selbst wenn dem so ist... Dann ist es Mist und vollkommen unnütz!



    Dass die Stromanforderungsfunktion in diesem Betriebszustand offensichtlich nicht schaltbar ist, dürfte Sicherheitsgründe haben.

    Ich wüsste nicht welche... Der Stirling hat den Pufferspeicher sowieso nur bis zur eingestellten maximal Temperatur aufgeheizt und dann abgeschaltet... Selbst wenn man vergessen hat die Funktion zu deaktivieren.

  • Dies ist jetzt unmöglich, da der Timer 5 keine Wirkung mehr hat. PLUS: Die Stromanforderungstaste hat keine Funktion mehr, wird in der Bedienungsanleitung aber immernoch als solche benannt.


    Nach Aussage von Viessmann wurde der Timer 5 in der Firmware zum "Sperrtimer" umfunktioniert... Angeblich hätten nicht genug Kunden den Stromanforderungsmodus verwendet, wollten mit dem Sperrtimer aber verhindern, dass der Stirling zu bestimmten Zeiten anspringt

    Aha. Mir scheint Du hast eine andere Software als wir, denn bei uns funktionieren (gottlob) alle diese Sachen noch.


    Welche Version hast Du denn? Bei unserem Modell C3HB wurde die Software im Sommer 2014 erneuert, als im Rahmen der "Viessmann Qualitätsoffensive" der Wärmetauscher etc. umgebaut wurde. Im Mai 2015 wurde unser Stirling getauscht. Wahrscheinlich wurden bei dieser Gelegenheit nochmals Änderungen an der Software vorgenommen. Jedenfalls: Laut Anzeige im Menü "Konfiguration" unter Code 6220 (F2) haben wir die Software-Version 01.4. In der Nachbarschaft findet man noch unter Code 6219 die "SW-Version Subsystem" (bei uns 01.9) und unter Code 6221 den "Entwicklungs-Index" (bei uns 15).


    Wenn bei Dir diese Zahlen höher sind, hast Du eine andere (neuere) Software-Version bekommen, bei der anscheinend einige "Verschlimmbesserungen" eingebaut wurden. In dem Fall vielen Dank für den Hinweis: Ich werde - falls bei uns einmal wieder der Kundendienst kommen sollte - scharf darauf achten, dass diese Version nicht in unser Gerät kommt - zumal dieses mit der jetzigen Software einwandfrei funktioniert ("never change a running system").


    Jedenfalls: Wenn die Software-Version die Ursache deiner Probleme ist, kannst Du nicht einfach bei Viessmann anfragen, ob sie bei Dir eine ältere Version der Software aufspielen können - z.B. die bei uns installierte?


    Übrigens, falls jemand von Viessmann hier mitliest - wenn ich einen Wunsch bezüglich Vitotwin-Software frei hätte, würde ich mir flexiblere Steuerungsmöglichkeiten für den Zusatzbrenner wünschen (d.h. über das grobmotorische Sperren unter Code 7222 hinaus), insbesondere:

    • Heizbetrieb: Sperren des Zusatzbrenners oberhalb einer einstellbaren Außentemperatur
    • TWW-Ladung: Separat einstellbare TWW-Nenntemperaturen und Schaltdifferenzen für Stirling und Zusatzbrenner.

    Die "Sperrtimer" Funktion finde ich gar nicht so blöd, aber als Ergänzung (nicht als Ersatz) für die Stromanforderungsfunktion. Auf letztere möchte ich jedenfalls unter keinen Umständen verzichten.


    Gruß, Sailor

    Viessmann Vitotwin 300-W (1 kWel, 6 kWth) seit 2012

    PV-Anlage 8,45 kWp (65 x Solarworld SW 130poly Ost/Süd/West, SMA 5000 TL und 3000) seit 2010

    Solarthermie 14 qm Flachkollektoren seit 2004 (Vorgänger 8 qm 1979-2003)

  • Aha. Mir scheint Du hast eine andere Software als wir, denn bei uns funktionieren (gottlob) alle diese Sachen noch.


    Welche Version hast Du denn? Bei unserem Modell C3HB wurde die Software im Sommer 2014 erneuert, als im Rahmen der "Viessmann Qualitätsoffensive" der Wärmetauscher etc. umgebaut wurde. Im Mai 2015 wurde unser Stirling getauscht. Wahrscheinlich wurden bei dieser Gelegenheit nochmals Änderungen an der Software vorgenommen. Jedenfalls: Laut Anzeige im Menü "Konfiguration" unter Code 6220 (F2) haben wir die Software-Version 01.4. In der Nachbarschaft findet man noch unter Code 6219 die "SW-Version Subsystem" (bei uns 01.9) und unter Code 6221 den "Entwicklungs-Index" (bei uns 15).

    Bei mir ist es Software-Version 0.1.4, Software-Subsystem 01.6 und Entwicklungs-Index 5..
    Mir scheint eher bei Dir wurden diese Bugs schon korrigiert. Bei mir noch nicht :(


    Ich werde Viessmann nochmal drauf ansprechen, weil ich das aktuell wirklich bescheiden finde.

  • Moin,

    Ich werde Viessmann nochmal drauf ansprechen

    Bitte mach' das und berichte dann hier, denn die Sache mit der Software wird immer mysteriöser.


    das ist seit dem Software-Update, also schon seit über 1 Jahr der Fall...

    Das Software-"Update" war bei Dir also irgendwann im Frühjahr 2015 - das heißt ein knappes Jahr später als bei uns der Viessmann-KD das Update gemacht hat, und etwa zeitgleich mit dem wahrscheinlichen weiteren Update bei uns im Mai 2015. Trotzdem hast Du anscheinend eine ältere Version (was auch immer die Bezeichnungen "Subsystem" und "Entwicklungs-Index" genau bedeuten). Hat da bei Dir der Viessmann-Techniker in die falsche Kiste gegriffen, oder war die falsche CD im Umschlag?


    Nach Aussage von Viessmann wurde der Timer 5 in der Firmware zum "Sperrtimer" umfunktioniert

    Aber das kann ja dann bei Dir nicht die Ursache für Dein Problem sein, denn diese Änderung (egal ob gut oder schlecht) hat es jedenfalls erst bei einer SW-Version gegeben, die jünger ist als unsere (geschweige denn Deine). Das "Zeitprogramm 5" und die Stromanforderungsfunktion hat es beim C3HA von Anfang an gegeben und jedenfalls in allen späteren SW-Versionen bis mindestens unserer. Nur die "Opt"-Funktion für das TWW wurde später hinzugefügt: Unser C3HA (der im Mai 2013 gegen einen C3HB getauscht wurde) hatte die noch nicht.


    Jedenfalls: Wenn Du schon mit Viessmann redest, könntest Du auch die Frage klären, ob das mit dem Wegfall der Stromanforderungs- bzw. Einführung der "Sperrtimer"-Funktion wirklich stimmt und ab welcher SW-Version diese Umstellung stattgefunden hat. Ich glaube, dass viele Vitotwin-Betreiber mit der Stromanforderungsfunktion arbeiten und unangenehm überrascht wären, wenn anlässlich eines Kundendienst-Besuches ein SW-Update stattfindet und danach die Steuerung nicht mehr so funktioniert wie gewünscht.


    Gruß, Sailor

    Viessmann Vitotwin 300-W (1 kWel, 6 kWth) seit 2012

    PV-Anlage 8,45 kWp (65 x Solarworld SW 130poly Ost/Süd/West, SMA 5000 TL und 3000) seit 2010

    Solarthermie 14 qm Flachkollektoren seit 2004 (Vorgänger 8 qm 1979-2003)

    Einmal editiert, zuletzt von sailor773 () aus folgendem Grund: Rechtschreibfehler gefunden

  • Hallo S.Malkwin,


    gerne würde ich mir die Sache mal näher anschauen. Kannst du mir bitte die Herstellnummer des Vitotwins und deine Kontaktdaten zur Verfügung stellen. Die E-Mail-Adresse lautet: social-media@viessmann.com. Bitte gib den Link zu diesem Beitrag und deinen Usernamen mit an.


    Gerne werde ich prüfen, wie wir hier weiter vorgehen können.


    Beste Grüße °jo